跳到主要内容

Luckfox Pico 2 Arduino 入门教程

本教程将介绍 Arduino,并指导您配置 Luckfox Pico 2 的 Arduino 开发环境。

重要提示:关于开发板的兼容性

本教程的核心逻辑适用于所有 Pico 系列开发板,但所有操作步骤均以 Luckfox Pico 2 为例进行讲解。如果您使用其他型号的开发板,请根据实际情况修改相应设置。

1. 什么是 Arduino IDE​

Arduino IDE 是一款开源开发环境,除了支持 Arduino 微控制器,还兼容包括 Luckfox Pico 2 在内的多种第三方开发板,使得开发者能够方便地编写和上传代码到这些强大的芯片上,实现各种项目。它拥有丰富的库和示例代码,广泛用于原型开发和教育领域。下面将讲解如何安装并使用 Arduino IDE 进行开发。

2. 下载安装 Arduino IDE​

  1. 前往 Arduino 官网 下载 Arduino IDE 安装程序。

    DownloadArduinoIDE

    提示

    如果下载速度慢或下载失败,可以访问 Arduino 中文社区,使用网盘下载社区提供的安装包。

  2. 运行安装程序安装 Arduino IDE。安装过程中建议使用默认设置,并选择纯英文路径进行安装。

    注意

    安装路径包含中文字符可能导致异常。

3. 设置 Arduino IDE​

  1. 安装完成后,启动 Arduino IDE。

  2. 首次启动时,IDE 可能会自动下载并安装核心库文件和驱动。若操作系统弹出驱动安装或网络安全提示,建议允许。下图所示的输出窗口信息为安装过程的提示信息,属于正常现象,无需处理。

    ImgArduinoInit
  3. Arduino IDE 默认显示英文界面,但支持切换到中文。点击"File - Preferences"打开设置。

    ImgOpenArduinoPreference

    在设置界面找到"Language"选项,选择"中文",然后点击"OK"。Arduino IDE 将自动重启并切换为中文界面。

    ImgArduinoPreferenceLanguage
  4. 此外,在“首选项”中还可调整界面缩放、字体大小、主题风格及项目默认保存位置等。

4. 安装 RP 系列开发板库​

要使用 Arduino IDE 对 Luckfox Pico 2 开发板进行开发,需要添加 RP 系列开发板相关配置并安装相关库。

  • 打开 “文件” -> “首选项”,在 “设置” 界面找到 “附加开发板管理器地址”,粘贴以下链接并点击确定:

    提示

    该链接已包含 Pico、Pico2 等版型,最新版型文件请访问 arduino-pico 获取

    https://github.com/earlephilhower/arduino-pico/releases/download/4.5.2/package_rp2040_index.json
    ImgArduinoAddPico
    注意

    如果您已经有 ESP32 板 URL,您可以使用逗号分隔 URL,如下所示

    https://dl.espressif.com/dl/package_esp32_index.json,https://github.com/earlephilhower/arduino-pico/releases/download/4.5.2/package_rp2040_index.json
  • 下载离线包

    Pico_Arduino 离线包下载地址

    下载后双击解压文件。

  • 将解压得到的 rp2040 文件夹,复制到 %LOCALAPPDATA%/Arduino15/packages 目录下

  • 重新打开 arduino,并进入开发板管理器,确认 rp2040 库已安装即可。

5. 第一次上传程序​

  1. 按住 Luckfox Pico 2 板上的 BOOTSET 按键,将 Luckfox Pico 2 通过 Micro USB 连接电脑,识别出可移动磁盘后松开按键。

    提示

    Luckfox Pico 2 采用 RP2350 芯片设计,开发板会被识别为 RP2350

    ImgArduinoUpload1
  2. 下载示例程序,打开路径:

    “文件” -> “示例” -> “01.Basics” -> “Blink”

  3. 点击 “工具” -> “端口”,记住当前已有的 COM 口(不要选择)。

    ImgArduinoUpload2
  4. 用 USB 线连接开发板,再次进入 “工具” -> “端口”,第一次连接请选择 UF2 Board。

    ImgArduinoUpload3
  5. 点击 “工具” -> “开发板” -> “Raspberry Pi Pico” ,根据开发板选择对应型号(如 Raspberry Pi Pico、Raspberry Pi Pico 2 等)。

    ImgArduinoUpload4
  6. 设置完成后,点击左上角 ➡ 按钮烧录程序。

    ImgArduinoUpload5
  7. 上传完成后再次点击 “工具” -> “端口”,连接新增的 COM 口。